Erro ou falha genérica

15/06/07 at 14:18 (Uncategorized)

Coisa linda essas aplicações de Visual Studio, né? Eu precisava rodar um programa na minha máquina e tudo que aparecia é o seguinte:

Falha na inicialização do aplicativo devido a configuração incorreta. A reinstalação do aplicativo pode resolver o problema.

Realmente brilhante, agora eu entendi o que aconteceu de errado. Aí eu vou no registro de eventos do Windows, e ele tem uma informação um pouco melhor:

Não foi possível encontrar Assembly dependente Microsoft.VC80.DebugCRT e o último erro foi A montagem a que foi feita referência não está instalada no sistema.

Tá, isso parece uma mensagem de erro mais detalhada, apesar de não fazer o menor sentido para mim. Mas procurando no google um pouco, encontro a seguinte pérola de como resolver este problema:

Since you are using debug versions of the DLLs you need to do one of the following:

1) Install Visual Studio 2005 on the IIS machine. This will install the necessary debug versions of MSVCR80.DLL etc to the WinSxS folder.

Que insight genial, para rodar um aplicativo simples, eu tenho que instalar um ambiente de desenvolvimento que é composto de alguns DVDs e custa milhares de dólares.
Felizmente, depois de recobrar o juízo, ele continua:

An easier solution is to switch to release builds instead of debug builds.

Você não adora o mundo microsoft? :P

Anúncios

Deixe um comentário

Preencha os seus dados abaixo ou clique em um ícone para log in:

Logotipo do WordPress.com

Você está comentando utilizando sua conta WordPress.com. Sair / Alterar )

Imagem do Twitter

Você está comentando utilizando sua conta Twitter. Sair / Alterar )

Foto do Facebook

Você está comentando utilizando sua conta Facebook. Sair / Alterar )

Foto do Google+

Você está comentando utilizando sua conta Google+. Sair / Alterar )

Conectando a %s

%d blogueiros gostam disto: